跳到主要内容

搭配 树莓派 Pico 使用

硬件连接​

模块引脚树莓派Pico
VCC3.3V
GNDGND
LCD_DINGP11
LCD_CLKGP10
LCD_CSGP9
LCD_DCGP14
LCD_RSTGP8
LCD_BLGP15
TP_SDAGP6
TP_SCLGP7
TP_RSTGP16
TP_IRQGP17

C/C++ 开发环境安装​

MicroPython 开发环境安装​

  • 下载Thonny IDE并按照步骤安装

  • 安装完成之后,第一次要配置语言和主板环境,由于我们是为了使用Pico,所以注意主板环境选择Raspberry Pi 选项。

    Pico-R3-Tonny1

  • 配置Micrpython环境及选择Pico端口。

    • 先将Raspberry Pi Pico 接入电脑,左键点击Thonny右下角的配置环境选项--》选择configture interpreter
    • 在弹出的窗口栏中选择MicroPython(Raspberry Pi Pico),同时选择对应的端口。

Raspberry-Pi-Pico-Basic-Kit-M-2

Raspberry-Pi-Pico-Basic-Kit-M-3

  • 点击ok后返回到Thonny主界面,下载固件库到Pico里面,然后点击停止按钮,在Shell窗口中即可显示当前使用到的环境。

  • Pico在windows下载固件库方法: 按住BOOT键后连接电脑后,松开BOOT键,电脑会出现一个可移动磁盘,将固件库复制进去即可。

树莓派环境下​

  • 打开树莓派终端,执行:

    sudo apt-get install p7zip-full
    cd ~
    sudo wget https://www.waveshare.net/w/upload/2/22/1.69inch_Touch_LCD_Pico.zip
    unzip 1.69inch_Touch_LCD_Pico.zip
    cd ~/1.69inch_Touch_LCD_Pico
    cd c/build/

例程使用​

C部分​

  • 以下教程为在树莓派 上操作,但由于cmake的多平台、可移植的特点,在PC上也是能成功编译,但操作略有不同,需要您自行判断。

进行编译,请确保在c目录:

cd ~/1.69inch_Touch_LCD_Pico/c/

创建并进入build目录,并添加SDK: 其中 ../../pico-sdk 是你的SDK的目录。 我们示例程序中是有build的,直接进入即可

cd build
export PICO_SDK_PATH=../../pico-sdk
(注意:务必写对你自己的SDK所在路径)

执行cmake自动生成Makefile文件

cmake ..

执行make生成可执行文件,第一次编译时间比较久

make -j9

编译完成,会生成uf2文件。 按住Pico板上的按键,将pico通过Micro USB线接到树莓派的USB接口,然后松开按键。接入之后,树莓派会自动识别到一个可移动盘(RPI-RP2),将build文件夹下的main.uf2 文件复制到识别的可移动盘(RPI-RP2)中即可。

cp main.uf2 /media/pi/RPI-RP2/

python​

  • 1.树莓派上将~/1.69inch_Touch_LCD_Pico/python/RPI_PICO-20240222-v1.22.2.uf2 文件拷入pico中。

  • 2.在树莓派上打开Thonny IDE (点击树莓logo -> Programming -> Thonny Python IDE ),你可以在Help->About Thonny查看版本信息

以确保你的版本是有Pico支持包的,同样你可以点击Tools -> Options... -> Interpreter选择MicroPython(Raspberry Pi Pico 和ttyACM0端口
如图所示:

Pico-lcd-0

如果你当前的Thonny版本没有pico支持包,输入以下指令来更新Thonny IDE

sudo apt upgrade thonny

3.点击File->Open...->~/1.69inch Touch LCD Pico/python/1.69inch_Touch_LCD.py,运行脚本即可

Windows环境下​

C部分​

  • 进入1.69inch_Touch_LCD_Pico\c后,使用vs code打开工程

1

  • 选择编译器

1

  • 开始编译

1

  • 编译完成

1

  • 将build中的main.uf2文件拷贝带Pico中,就会自动运行程序了。

1

python​

  • 1.按住Pico板上的BOOTSET按键,将pico通过Micro USB线接到电脑的USB接口,待电脑识别出一个可移动硬盘(RPI-RP2)后,松开按键。

  • 2.将python目录中RPI_PICO-20240222-v1.22.2.uf2 文件复制到识别的可移动盘(RPI-RP2)中

  • 3.打开Thonny IDE(注意:要使用最新版本的Thonny,否则是没有Pico的支持包的,当前Windows下的最新版本为v3.3.3)

  • 4.点击工具->设置->解释器,如图所示选择Pico及对应的端口

Pico-lcd-0

  • 5.文件->打开->1.28inch_Touch_LCD.py,点击运行即可,如下图所示:

LCD 1inch47 3

本例程提供了一个简单的程序...

代码简析​

C​

底层硬件接口​

我们进行了底层的封装,由于硬件平台不一样,内部的实现是不一样的,如果需要了解内部实现可以去对应的目录中查看
在DEV_Config.c(.h)可以看到很多定义,在目录:...\c\lib\Config

  • 数据类型:

    #define UBYTE uint8_t
    #define UWORD uint16_t
    #define UDOUBLE uint32_t
  • 模块初始化与退出的处理:

    void DEV_Module_Init(void);
    void DEV_Module_Exit(void);
    注意:
    1.这里是处理使用液晶屏前与使用完之后一些GPIO的处理。
  • GPIO读写:

    void DEV_Digital_Write(UWORD Pin, UBYTE Value);
    UBYTE DEV_Digital_Read(UWORD Pin);
  • SPI写数据

    void DEV_SPI_WriteByte(UBYTE Value);
  • I2C读写数据

    void DEV_I2C_Write_Byte(uint8_t addr, uint8_t reg, uint8_t Value);
    void DEV_I2C_Write_nByte(uint8_t addr, uint8_t *pData, uint32_t Len);
    uint8_t DEV_I2C_Read_Byte(uint8_t addr, uint8_t reg);
    void DEV_I2C_Read_nByte(uint8_t addr, uint8_t reg, uint8_t *pData, uint32_t Len);

上层应用​

对于屏幕而言,如果需要进行画图、显示中英文字符、显示图片等怎么办,这些都是上层应用做的。这有很多小伙伴有问到一些图形的处理,我们这里提供了一些基本的功能 在如下的目录中可以找到GUI,在目录:..\c\lib\GUI\GUI_Paint.c(.h)

LCD PICO GUI 1

在如下目录下是GUI依赖的字符字体,在目录:RaspberryPi\c\lib\Fonts

LCD rpi Font

  • 新建图像属性:新建一个图像属性,这个属性包括图像缓存的名称、宽度、高度、翻转角度、颜色

    void Paint_NewImage(UWORD *image, UWORD Width, UWORD Height, UWORD Rotate, UWORD Color)
    参数:
    image : 图像缓存的名称,实际上是一个指向图像缓存首地址的指针;
    Width : 图像缓存的宽度;
    Height: 图像缓存的高度;
    Rotate:图像的翻转的角度
    Color :图像的初始颜色;
  • 选择图像缓存:选择图像缓存,选择的目的是你可以创建多个图像属性,图像缓存可以存在多个,你可以选择你所创建的每一张图像

    void Paint_SelectImage(UBYTE *image)
    参数:
    image: 图像缓存的名称,实际上是一个指向图像缓存首地址的指针;
  • 设置点在缓存中显示位置和颜色:这里是GUI最核心的一个函数、处理点在缓存中显示位置和颜色;

    void Paint_SetPixel(UWORD Xpoint, UWORD Ypoint, UWORD Color)
    参数:
    Xpoint: 点在图像缓存中X位置
    Ypoint: 点在图像缓存中Y位置
    Color : 点显示的颜色
  • 图像缓存填充颜色:把图像缓存填充为某颜色,一般作为屏幕刷白的作用

    void Paint_Clear(UWORD Color)
    参数:
    Color: 填充的颜色
  • 图像缓存部分窗口填充颜色:把图像缓存的某部分窗口填充为某颜色,一般作为窗口刷白的作用,常用于时间的显示,刷白上一秒

    void Paint_ClearWindows(UWORD Xstart, UWORD Ystart, UWORD Xend, UWORD Yend, UWORD Color)
    参数:
    Xstart: 窗口的X起点坐标
    Ystart: 窗口的Y起点坐标
    Xend: 窗口的X终点坐标
    Yend: 窗口的Y终点坐标
    Color: 填充的颜色
  • 画点:在图像缓存中,在(Xpoint, Ypoint)上画点,可以选择颜色,点的大小,点的风格

    void Paint_DrawPoint(UWORD Xpoint, UWORD Ypoint, UWORD Color, DOT_PIXEL Dot_Pixel, DOT_STYLE Dot_Style)
    参数:
    Xpoint: 点的X坐标
    Ypoint: 点的Y坐标
    Color: 填充的颜色
    Dot_Pixel: 点的大小,提供默认的8种大小点
    typedef enum {
    DOT_PIXEL_1X1 = 1, // 1 x 1
    DOT_PIXEL_2X2 , // 2 X 2
    DOT_PIXEL_3X3 , // 3 X 3
    DOT_PIXEL_4X4 , // 4 X 4
    DOT_PIXEL_5X5 , // 5 X 5
    DOT_PIXEL_6X6 , // 6 X 6
    DOT_PIXEL_7X7 , // 7 X 7
    DOT_PIXEL_8X8 , // 8 X 8
    } DOT_PIXEL;
    Dot_Style: 点的风格,大小扩充方式是以点为中心扩大还是以点为左下角往右上扩大
    typedef enum {
    DOT_FILL_AROUND = 1,
    DOT_FILL_RIGHTUP,
    } DOT_STYLE;
  • 画线:在图像缓存中,从 (Xstart, Ystart) 到 (Xend, Yend) 画线,可以选择颜色,线的宽度,线的风格

    void Paint_DrawLine(UWORD Xstart, UWORD Ystart, UWORD Xend, UWORD Yend, UWORD Color, LINE_STYLE Line_Style , LINE_STYLE Line_Style)
    参数:
    Xstart: 线的X起点坐标
    Ystart: 线的Y起点坐标
    Xend: 线的X终点坐标
    Yend: 线的Y终点坐标
    Color: 填充的颜色
    Line_width: 线的宽度,提供默认的8种宽度
    typedef enum {
    DOT_PIXEL_1X1 = 1, // 1 x 1
    DOT_PIXEL_2X2 , // 2 X 2
    DOT_PIXEL_3X3 , // 3 X 3
    DOT_PIXEL_4X4 , // 4 X 4
    DOT_PIXEL_5X5 , // 5 X 5
    DOT_PIXEL_6X6 , // 6 X 6
    DOT_PIXEL_7X7 , // 7 X 7
    DOT_PIXEL_8X8 , // 8 X 8
    } DOT_PIXEL;
    Line_Style: 线的风格,选择线是以直线连接还是以虚线的方式连接
    typedef enum {
    LINE_STYLE_SOLID = 0,
    LINE_STYLE_DOTTED,
    } LINE_STYLE;
  • 画矩形:在图像缓存中,从 (Xstart, Ystart) 到 (Xend, Yend) 画一个矩形,可以选择颜色,线的宽度,是否填充矩形内部

    void Paint_DrawRectangle(UWORD Xstart, UWORD Ystart, UWORD Xend, UWORD Yend, UWORD Color, DOT_PIXEL Line_width, DRAW_FILL Draw_Fill)
    参数:
    Xstart: 矩形的X起点坐标
    Ystart: 矩形的Y起点坐标
    Xend: 矩形的X终点坐标
    Yend: 矩形的Y终点坐标
    Color: 填充的颜色
    Line_width: 矩形四边的宽度,提供默认的8种宽度
    typedef enum {
    DOT_PIXEL_1X1 = 1, // 1 x 1
    DOT_PIXEL_2X2 , // 2 X 2
    DOT_PIXEL_3X3 , // 3 X 3
    DOT_PIXEL_4X4 , // 4 X 4
    DOT_PIXEL_5X5 , // 5 X 5
    DOT_PIXEL_6X6 , // 6 X 6
    DOT_PIXEL_7X7 , // 7 X 7
    DOT_PIXEL_8X8 , // 8 X 8
    } DOT_PIXEL;
    Draw_Fill: 填充,是否填充矩形的内部
    typedef enum {
    DRAW_FILL_EMPTY = 0,
    DRAW_FILL_FULL,
    } DRAW_FILL;
  • 画圆:在图像缓存中,以 (X_Center Y_Center) 为圆心,画一个半径为Radius的圆,可以选择颜色,线的宽度,是否填充圆内部

    void Paint_DrawCircle(UWORD X_Center, UWORD Y_Center, UWORD Radius, UWORD Color, DOT_PIXEL Line_width, DRAW_FILL Draw_Fill)
    参数:
    X_Center: 圆心的X坐标
    Y_Center: 圆心的Y坐标
    Radius:圆的半径
    Color: 填充的颜色
    Line_width: 圆弧的宽度,提供默认的8种宽度
    typedef enum {
    DOT_PIXEL_1X1 = 1, // 1 x 1
    DOT_PIXEL_2X2 , // 2 X 2
    DOT_PIXEL_3X3 , // 3 X 3
    DOT_PIXEL_4X4 , // 4 X 4
    DOT_PIXEL_5X5 , // 5 X 5
    DOT_PIXEL_6X6 , // 6 X 6
    DOT_PIXEL_7X7 , // 7 X 7
    DOT_PIXEL_8X8 , // 8 X 8
    } DOT_PIXEL;
    Draw_Fill: 填充,是否填充圆的内部
    typedef enum {
    DRAW_FILL_EMPTY = 0,
    DRAW_FILL_FULL,
    } DRAW_FILL;
  • 写Ascii字符:在图像缓存中,在 (Xstart Ystart) 为左顶点,写一个Ascii字符,可以选择Ascii码可视字符字库、字体前景色、字体背景色

    void Paint_DrawChar(UWORD Xstart, UWORD Ystart, const char Ascii_Char, sFONT* Font, UWORD Color_Foreground, UWORD Color_Background)
    参数:
    Xstart: 字符的左顶点X坐标
    Ystart: 字体的左顶点Y坐标
    Ascii_Char:Ascii字符
    Font: Ascii码可视字符字库,在Fonts文件夹中提供了以下字体:
    font8:5*8的字体
    font12:7*12的字体
    font16:11*16的字体
    font20:14*20的字体
    font24:17*24的字体
    Color_Foreground: 字体颜色
    Color_Background: 背景颜色
  • 写英文字符串:在图像缓存中,在 (Xstart Ystart) 为左顶点,写一串英文字符,可以选择Ascii码可视字符字库、字体前景色、字体背景色

    void Paint_DrawString_EN(UWORD Xstart, UWORD Ystart, const char * pString, sFONT* Font, UWORD Color_Foreground, UWORD Color_Background)
    参数:
    Xstart: 字符的左顶点X坐标
    Ystart: 字体的左顶点Y坐标
    pString:字符串,字符串是一个指针
    Font: Ascii码可视字符字库,在Fonts文件夹中提供了以下字体:
    font8:5*8的字体
    font12:7*12的字体
    font16:11*16的字体
    font20:14*20的字体
    font24:17*24的字体
    Color_Foreground: 字体颜色
    Color_Background: 背景颜色
  • 写中文字符串:在图像缓存中,在 (Xstart Ystart) 为左顶点,写一串中文字符,可以选择GB2312编码字符字库、字体前景色、字体背景色;

    void Paint_DrawString_CN(UWORD Xstart, UWORD Ystart, const char * pString, cFONT* font, UWORD Color_Foreground, UWORD Color_Background)
    参数:
    Xstart: 字符的左顶点X坐标
    Ystart: 字体的左顶点Y坐标
    pString:字符串,字符串是一个指针
    Font: GB2312编码字符字库,在Fonts文件夹中提供了以下字体:
    font12CN:ascii字符字体11*21,中文字体16*21
    font24CN:ascii字符字体24*41,中文字体32*41
    Color_Foreground: 字体颜色
    Color_Background: 背景颜色
  • 写数字:在图像缓存中,在 (Xstart Ystart) 为左顶点,写一串数字,可以选择Ascii码可视字符字库、字体前景色、字体背景色

    void Paint_DrawNum(UWORD Xpoint, UWORD Ypoint, double Nummber, sFONT* Font, UWORD Digit,UWORD Color_Foreground, UWORD Color_Background);
    参数:
    Xstart: 字符的左顶点X坐标
    Ystart: 字体的左顶点Y坐标
    Nummber:显示的数字,这里使用的是32位长的int型保存,可以最大显示到2147483647
    Font: Ascii码可视字符字库,在Fonts文件夹中提供了以下字体:
    font8:5*8的字体
    font12:7*12的字体
    font16:11*16的字体
    font20:14*20的字体
    font24:17*24的字体
    Digit:显示小数点位数
    Color_Foreground: 字体颜色
    Color_Background: 背景颜色
  • 显示时间:在图像缓存中,在 (Xstart Ystart) 为左顶点,显示一段时间,可以选择Ascii码可视字符字库、字体前景色、字体背景色;

    void Paint_DrawTime(UWORD Xstart, UWORD Ystart, PAINT_TIME *pTime, sFONT* Font, UWORD Color_Background, UWORD Color_Foreground)
    参数:
    Xstart: 字符的左顶点X坐标
    Ystart: 字体的左顶点Y坐标
    pTime:显示的时间,这里定义好了一个时间的结构体,只要把时分秒各位数传给参数;
    Font: Ascii码可视字符字库,在Fonts文件夹中提供了以下字体:
    font8:5*8的字体
    font12:7*12的字体
    font16:11*16的字体
    font20:14*20的字体
    font24:17*24的字体
    Color_Foreground: 字体颜色
    Color_Background: 背景颜色

MicroPython(适用于Raspberry Pi Pico)​

  • 基本库使用可以查看此链接,更多可点击此处查看。
  • 图形库使用可以查看此链接。
  • 温馨提示,此处都为英文,英文水平差的国内小伙伴可以搭配翻译软件使用,有问题可咨询我们。