跳到主要内容

ESP32-S3 开发

硬件连接​

使用 15PIN 杜邦线按照下表连接模块与 ESP32-S3:

LCD 引脚ESP32-S3
VCCNC
3V33V3
GNDGND
MISOGPIO 42
MOSIGPIO 2
SCLKGPIO 1
SD_CSGPIO 38
LCD_CSGPIO 39
LCD_DCGPIO 41
LCD_RSTGPIO 40
LCD_BLGPIO 6
TP_SDAGPIO 15
TP_SCLGPIO 7
TP_INTGPIO 17
TP_RSTGPIO 16

配置 Arduino IDE​

  1. 按照 安装和配置 Arduino IDE 教程 安装 Arduino IDE 和 Arduino ESP32 Core。

    Arduino IDE 下载页面

  2. 下载并解压 2inch Capacitive Touch LCD ESP32-S3 示例程序。

  3. 将示例程序包内的 GFX_Library_for_Arduino 库安装到 Arduino IDE。该库需离线安装,详细方法请参考上述 Arduino IDE 教程中的库管理章节。

Arduino IDE 基础操作​

如果尚未使用 Arduino IDE 编译和上传过 ESP32-S3 程序,可通过以下测试程序检查开发环境:

  1. 选择 "File" > "New Sketch" 新建项目:

    在 Arduino IDE 中新建项目

  2. 输入以下代码,并选择 "File" > "Save As" 保存项目:

    void setup() {
    Serial.begin(115200);
    }

    void loop() {
    Serial.println("Hello, World!");
    delay(2000);
    }

    保存 Arduino ESP32-S3 测试项目

  3. 选择 "ESP32S3 Dev Module" 和开发板对应的串口:

    在 Arduino IDE 中选择 ESP32-S3 开发板和串口

  4. 如果开发板仅提供原生 USB 接口,在 "Tools" 菜单中将 "USB CDC On Boot" 设置为 "Enabled":

    在 Arduino IDE 中启用 USB CDC On Boot

  5. 编译并上传程序。上传完成后,Arduino IDE 输出窗口会显示复位提示:

    Arduino ESP32-S3 测试程序上传完成

  6. 打开串口监视器并将波特率设置为 115200。串口监视器每隔 2 秒输出一次 Hello, World!:

    Arduino ESP32-S3 测试程序串口输出

运行示例​

  1. 使用 Arduino IDE 打开 2inch_Capacitive_Touch_LCD_Demo_ESP32S3/2inch_Capacitive_Touch_LCD 示例。

    在 Arduino IDE 中打开 2inch Capacitive Touch LCD ESP32-S3 示例

  2. 根据实际使用的 ESP32-S3 开发板选择开发板型号和串口,并按开发板资源调整示例中的引脚配置。

    配置 2inch Capacitive Touch LCD ESP32-S3 示例的开发板选项

  3. 如果开发板仅提供原生 USB 接口,请在 Arduino IDE 中启用 "USB CDC On Boot"。

  4. 编译并上传程序。

    2inch Capacitive Touch LCD ESP32-S3 示例上传完成

程序运行后,屏幕进入触控画板界面。打开串口监视器,还可查看程序识别到的 Micro SD 卡容量。

2inch Capacitive Touch LCD ESP32-S3 示例串口输出