跳到主要内容

HexArth Arduino 使用说明

二次开发工具使用​

本教程将介绍二次开发工具的安装与使用方法,重点说明如何为 HexArth 机器人上传修改后的程序,帮助用户在开源机器人程序基础上进行二次开发。本次使用的开发工具为 Arduino IDE,下文将详细介绍 Arduino IDE 中机器人依赖库及开发环境的安装与使用。

Arduino IDE 是什么​

Arduino IDE(Integrated Development Environment,集成开发环境)是一个基于开源代码的开发平台,具备独立的编程语言与开发环境。Arduino IDE 提供丰富的库文件,大幅简化了诸如显示器、传感器等复杂硬件及软件平台的使用过程。

Arduino IDE 安装​

1. 下载 Arduino IDE​

先到 Arduino 官网 下载最新版本 Arduino IDE 的安装包。官方 IDE 支持不同操作系统下载,根据您的操作系统进行选择。这里下载的是 Windows 的,如果已安装,直接跳到第二步。安装过程很简单,一直点击下一步即可。

注意

安装过程中会提示安装驱动,一直点击安装即可。

2. 设置 Arduino IDE 为中文界面​

第一次安装完成后,打开 Arduino IDE 是英文界面的,可以点击“File”→“Preferences”。

在“Language”里面选择简体中文,点击 OK。

开发环境安装​

机器人上驱动板的主控模组是 ESP32,所以我们在 Arduino IDE 开发环境中需要安装好 ESP32 对应的开发板。步骤如下:

  1. 打开 Arduino IDE,点击“文件”→“首选项”。

  2. 在附加开发板管理器网址中添加如下链接,点击“确定”保存设置。

    https://dl.espressif.com/dl/package_esp32_index.json
    注意

    如果您需要添加多个开发板 URL,那无需将 ESP32 开发板支持的 URL 删掉,可以直接将其他 URL 添加至另一行,默认显示是逗号分隔开 URL 的。

    例如:如果您需要添加 ESP8266 开发板的 URL,直接添加至另一行,显示出来如下为:

    https://dl.espressif.com/dl/package_esp32_index.json,http://arduino.esp8266.com/stable/package_esp8266com_index.json
  3. 点击 ESP32 开发包网盘的链接:ESP32 开发包,进行下载并解压缩,在“我的电脑”中输入以下路径:

    C:\Users\username\AppData\Local\Arduino15

    username 需要根据自己电脑的用户名更改,新建一个 packages 文件夹,将解压后的文件夹中的 esp32 开发包复制到 packages 文件夹下。

    可以从 packages-esp32-hardware-esp32 中看见安装的 ESP32 开发板为 3.0.7 版本的,HexArth 的开源程序开发板 ESP32 的版本为 3.0.7。

依赖库安装​

下载 依赖库文件,进行解压缩,打开 Arduino IDE 默认安装位置:C:\Users\username\AppData\Local\Arduino15\libraries(结合自己实际位置),再把图中文件夹复制到 libraries 文件夹里。

上传程序​

  1. 下载 HexArth 下位机开源程序,解压后双击打开 HexArth_example.ino。注意这个目录下的所有文件要在同一个文件夹下。

  2. 点击“工具”→“端口”,记住自己电脑上已有的 COM,不需要点击这个 COM(此时我这里显示的 COM 为 COM1,不同电脑已有的会显示不一样的 COM)。

  3. 用 USB 线将 HexArth 机器人上的驱动板和计算机连接起来(注意要连接左边的 USB 接口),点击“工具”→“端口”,再点击新出现的 COM(我这里新出现的 COM 为 COM29)。

  4. 在 Arduino IDE 中,点击“工具”→“开发板”→“ESP32”→“ESP32 Dev Module”。

  5. 点击“工具”,其他设置如下:(Partition Scheme 最好用 Huge APP,PSRAM 必须使用 Enabled)

  6. 设置全部完成后,点击“上传”将程序上传至机器人的驱动板上。

    注意

    如果上传期间遇到了问题,需要重新安装或者更换 Arduino IDE 版本时,在这之前,您需要将 Arduino IDE 卸载干净,卸载软件后需要将 C:\Users\username\AppData\Local\Arduino15 这个文件夹内的所有内容手动删除(一些隐藏文件需要显示才能看到),接着再重新下载安装。